Play Home Contribute Github Join Us! Discourse Staff Members Github Contribution Guides Team

I need support with flags

Hi all, I’ve played CC before with no issues, however I reset my account and I’m going through everything again. I’ve gotten to the point where I have access to flags but I can’t place them unless it’s in an area where my char can’t go (e.g. forest tile). I’ve cleared my Chrome browser cache and also tried Firefox and getting the same results. Any ideas?

1 Like

What level are you on? And just to cover the basics, are you placing flags in the submissions. Also, what flag are you using?

1 Like

Hello, I’m on level “Cornucopia” (Forest Area). Yep, I’m in the submission mode and I’ve tried all 3 flags. My code isn’t looking for a specific colour.

1 Like

Also just tried naming a specific colour flag with no success. I’ve noticed that I can place the flag in seemingly random locations if I click around, but like I said earlier, I can definitely place it in out-of-bounds areas.

1 Like

I am having the same problem. I can place the first flag and then every once in a while it will let me place a flag in the playable area, but not reliably. It will place them out of bounds on every click.

1 Like

Just to make sure this level does not hold you up in your progress, add some code to collect the coins without the flags, if you haven’t already.

3 Likes

Completed coinucopia with regular moveXY, but the bug is also happening on the next level.

1 Like

I see what you mean. I’m able to place enough flags to pass the level, but it is not placing all the flags it should be.

The first four levels are in Backwoods.
Coinucopia
Copper Meadows
Drop the Flag
Rich Forager
Yakstraction - Desert

1 Like

I managed to luck my way around the bug on Coinucopia, and the flags worked for me on Drop The Flag. I’ve come across this bug again on the level Yakstraction (Desert).

1 Like

Thanks for the notification. While this level doesn’t need flags to pass, it can make it easier. Let us know if you find anymore. Thanks

Fixed via:

2 Likes

I also have an issue where the code has no errors, but I can’t place down flags after clicking submit even after I’ve chosen the color of the flag. Please help!

Welcome, apparently there are some issues with the flags on a few levels right now. The post below will help you pass the level for now.

hey please help me with coinucopia because he says that I must click on the computer for flags but if I click then happends nothing

Hi, please could you also post your code (formatted as it says in the FAQ), and some screenshots if possible.
Thanks,
:lion: :lion: :lion:

1 Like

this is my code
while True:
flag = hero.findFlag()
if flag:
hero.pickUpFlag(flag)
else:
hero.say(“Plaats een vlag op de plek waar ik naartoe moet lopen.”)

and this is a screenshot

Please format your code according to the rules. Also if you speak a different language, please confirm what language you are speaking so that we may easily be able to communicate with you.

Check my post about flags not working. We ran into this a few days ago and it isn’t just Coinucopia. Further down you will see a list of a few more levels not working correctly.

1 Like

This issue has been solved according to this post:
https://discourse.codecombat.com/t/flag-problems-on-multiple-levels/18677/10?u=luke10