Play Home Contribute Github Join Us! Discourse Staff Members Github Contribution Guides Team

Last Guardian bug

I recently tried the newly available (to the campaign at least) level ‘Last Guardian’.
However, when I clicked on the level and pressed play it skipped the inventory stage, which would’ve been fine if the correct gear was loaded into the level, but when the level opened I had Claymore equipped rather than the long sword. Whenever I tried to write any code, even without cleave, the level froze and created an infinite loop. I also saw on the level editor that cleave was a required property, which might have caused a problem when cleave wasn’t available to the hero.
I tried doing the thing where you load equipment into another level, then play the original level again in the hope that it would also load the gear into that level, but it didn’t change the loaded gear.
@Chaboi_3000 would it be possible to add an inventory stage to this level so that the player could equip the long sword before entering the level? Or do you think this problem is unrelated?
Thanks
Danny

I will check the level tomorrow. :+1: