Possible item equip bug


#1

Before entering the village guard level, I attempted to equip the item “simple wristwatch”. This item appeared to disappear into the slot where the “programmaticon II” was/is located in the equipped items.

The “programmaticon II” appears to be acting normally. I can unequip and reequip it but the “simple wristwatch” is nowhere to be found in inventory nor in equip items. It is marked as purchased, however.

Upon attempting to load into any level, progress appears to halt and level never loads.


#2

Thanks for the bug report; I think I’ve fixed the problem with the simple wristwatch. Give it another shot now and let me know how it goes.


#3

Thank you for the fast response! :slight_smile:

I still can’t seem to successfully load into levels, though the console has changed. http://puu.sh/dbTeX/53bf0c700f.png

This is while attempting to enter a level with the following items.

I think I may still have the wristwatch equip somehow.


#4

But it does now have that Component, though… It sounds like the fix somehow hasn’t propagated to you. Can you try clearing your browser cache and letting me know whether anything changes about the “ThangType Simple Wristwatch does not have dependent Component Acts from Waits” error message?


#5

Just tried clearing cache/cookies ect. Disabled all extensions. Reinstalled chrome. No change unfortunately.

Also attempted in firefox, but same things happen there.


#6

That’s pretty weird! I also just tried doing it with your account setup, but it is working here. Are you behind any sort of unusually strong caching proxy server or something like that? (What’s your internet setup like?)


#7

I do not have any proxies setup at the moment. My network setup for this computer uses an Ethernet connection via powerline to my router which is connected to my modem via another Ethernet cable, which is then connected to the cable line. (Charter communications)

Upon login today, I noticed the wristwatch now appears in the view of equipped items in its proper place whereas it did not yesterday. I attempted to load into the level with it there, but it still does not load and console still returns the same " ThangType Simple Wristwatch does not have dependent Component Acts from Waits" messages.

I am now able to un-equip the wristwatch now that it is visible in the ui, though. Upon un-equipping, I am able to successfully load and complete levels again. If I re-equip the wristwatch, the problem returns.


#8

It appears we may have some cache expiration problems that I hoped we wouldn’t have. Can you visit http://codecombat.com/editor/thang/simple-wristwatch and click the Components tab and let me know if it shows the Waits Component for you? If not, can you also check http://direct.codecombat.com/editor/thang/simple-wristwatch and see if that has it? Thanks!