Item icons not loading


#1

I use codecombat on a wide variety of low end computers due to my job. Some can barely run it (our very very low end Chromebooks), and others do better (my cheap laptop) I have noticed that from time to time when I am loading levels, or worse, when I change heroes while in a level, the available items don’t always load their icons. They are still selectable, the icons just don’t show up.

This example is from the cheap laptop, which is:

Windows 8.1 (It burns!)
i5-3337u @ 1.8 GHz
6GB RAM
64 bit system
Onboard terrible Intel HD Graphics 4000 adapter


#2

Does the item icon eventually show up if you scroll the item list and wait? I know there is a bug where the icon won’t show up if you buy an item until you equip or unequip some other item, but this sounds like another problem.


#3

Nope, it stays gone. If you click on the empty space it will show the item description, but still has a blank icon.


#4

I tried to reproduce the bug again by trying to change heros in the middle of a level (that often gets me buggy) and I got this:


I can’t scroll or click any items, I can however close the frame and go back to the level. Willing to remote host if you want to try…


#5

Do you ever see the problem on a faster computer? (I’m wondering if it has to do with the lower performance machines triggering race conditions in our code…)

Tracking a related problem here: https://github.com/codecombat/codecombat/issues/1980


#6

lol… I don’t have access to a “faster” computer. It seems to be less prevalent the better the computer is running, but that is a personal observation, not data.


#7

I get that same view (items but invisible hero). It seems to happen when I click to quickly on “next” to get to the screen above. After clicking “Change Hero”, If I wait for the hero to load and start “acting out” :smile: before I click “next” I don’t seem to get the invisible hero.

–Edit–
Actually, I am having trouble getting this to happen today. (worked a day or to ago.)