No achievements


#1

I keep running into this error message when doing adventurer levels:

I am using Firefox 47.0.1 on Windows 7.


#2

I’m getting the same error - I just made an account and I can’t advance past the first level.

I’m using Safari 9.1.2, OS X El Capitan 10.11.6, if that helps anything.


#3

Update: It also doesn’t work on Vivaldi 1.2.490.43 (32-bit).


#4

I was getting the same error, but actually is fixed, I think it was an internal problem


#5

Same error here as well, and just like @kristoffsky, I just made an account and can’t advance past the first level.

I’m on Windows Vista, Google Chrome Version 49.0.2623.112 m. I also downloaded and checked on Firefox 43.01, I believe, but that worked even less.

I even tried restarting my progress, and it wouldn’t let me (said I had the wrong email, even though I didn’t).

EDIT: Working for me now. Tried playing the first level again and it allowed me to progress.


#6

We inadvertently broke achievements briefly.

Sorry!