Replays never loading


#1

Whenever I try to load a replay, it just comes up with a blank screen. Why is this?


#2

Please define “blank screen” or provide screenshot, thanks.


#3

Hm…Have you ever tried to load a world that doesn’t exist? For example, type this URL in: “codecombat.com/play/(insert non-existent world here)”. What the page comes up as is that I mean by “blank screen.”


#4

Cool.
(it’s been a while since I’ve seen anything but “Page not found” so, I’d forgotten that “…/play/…” barfs with an empty view.)

So, (to continue my prodding for useful info) :smile:

  • exactly what are you doing to “load a replay”.
  • Do you mean “watch” from the scores list,
  • or “spectate from the ladder”
  • or ???
  • What browser and OS are you having this problem on?
  • Are there any errors in the javascript console?

As we like to say, “Help us help you.”


#5

I mean by “loading a replay” watching someone beat a level.
I am using Safari, with OSX 10.8.5.
What is this JavaScript console you speak of?


#6

How To Open Javascript Console in Different Browsers

So you mean? “Watch” from the scores list?


#7

Yes, I do mean that.


#8

Is there a particular URL that doesn’t load? I’ll check it out.


#9

No, every level replay I’ve tried has the same result.


#10

I’ve reported something similar a while ago. I’ve tried several times since then, and it seems replays work rather fine (even though most of the time it’s a loss because the seed has changed), but doesn’t work at all when it’s a “hacked-in” submission with incredible score.

Most of these scores are early in the game (Kithgard Brawl is most hacked in, Backwoods brawl second) and contains a long list of “viewable” replays that are in fact just crap. Ex : URL to the replay of Rusokrd, score 20 at backwoods Brawl. Here is what this url brings me :

Later in the game, when I can find a respectable player submission, it works fine, like the ones of KevinHolland or Glacian or NishaNoire. Never found a bad replay so far, exept crazy warrior ones. (tested about 20, not a complete test).


#11

I can’t even see my replays, and I assure you that my submits are genuine.


#12

Update: The JavaScript console has no error, except for a Syntax Error that says
[Error] SyntaxError: audio resources unavailable for AudioContext construction.