Play Home Contribute GitHub Join Us Discourse Staff Members GitHub Contribution Guides Team

Should a methodname be translated?


In Kithgard 16/43, the text reads:
‘Benutze findNearestEnemy(), um auf den nächsten Gegner zu zielen.
var nächsterGegner = held.findeNächstenGegner();’

That might not only confuse somebody who doesn’t know that ‘findNearestEnemy()’ translates to ‘findeNächstenGegner()’, but if you try to actually use ‘held.findeNächstenGegner()’, the object ‘held’ is undefined (as could be expected).
It would appear more intuitive to use ‘var nextEnemy = hero.findNearestEnemy();’ in the translation, or am I off there?


It’ll be a pain to translate the code itself. Since translating all of the methods will take a while and developers will have to recode a lot of things. I’ll think it’s better off being the way it is.